Forge Home

tomcat6

A puppet module that installs tomcat6 on EL/Debian platforms

17,569 downloads

15,498 latest version

3.5 quality score

We run a couple of automated
scans to help you access a
module's quality. Each module is
given a score based on how well
the author has formatted their
code and documentation and
modules are also checked for
malware using VirusTotal.

Please note, the information below
is for guidance only and neither of
these methods should be considered
an endorsement by Puppet.

Version information

  • 0.0.6 (latest)
  • 0.0.5
  • 0.0.3
  • 0.0.1
released Feb 22nd 2014

Start using this module

  • r10k or Code Manager
  • Bolt
  • Manual installation
  • Direct download

Add this module to your Puppetfile:

mod 'yguenane-tomcat6', '0.0.6'
Learn more about managing modules with a Puppetfile

Add this module to your Bolt project:

bolt module add yguenane-tomcat6
Learn more about using this module with an existing project

Manually install this module globally with Puppet module tool:

puppet module install yguenane-tomcat6 --version 0.0.6

Direct download is not typically how you would use a Puppet module to manage your infrastructure, but you may want to download the module in order to inspect the code.

Download

Documentation

yguenane/tomcat6 — version 0.0.6 Feb 22nd 2014

puppet-tomcat6 Build Status

A puppet module that installs the Tomcat Java Servlet Container

About

This module installs Tomcat 6 from your package system.

On Entreprise Linux based system, packages are retrieved from JPackage repositories. By default it will retrieve the packages from JPackage 6.0, if for some reason you want to get them installed from JPackage 5.0 please edit the module, by doing the following in init.pp

change

require jpackage

by

class{'jpackage':
  version => '5.0',
  before  => Package['tomcat6'],
}

Usage

Simplest form

inlcude tomcat6

If you have parameters you wan to specify

class {'tomcat6':
  java_opts => '-Djava.awt.headless=true -Xmx128m -XX:+UseConcMarkSweepGC',
  lang => 'fr_FR',
  tomcat_user => my_tomcat_user',
}

Tests

It has been tested on

  • CentOS 5
  • CentOS 6
  • Debian 6