Forge Home
Premium module

sce_linux

Security Compliance Enforcement for Linux

88 downloads

88 latest version

5.0 quality score

We run a couple of automated
scans to help you access a
module's quality. Each module is
given a score based on how well
the author has formatted their
code and documentation and
modules are also checked for
malware using VirusTotal.

Please note, the information below
is for guidance only and neither of
these methods should be considered
an endorsement by Puppet.

Security Compliance Enforcement is a premium feature for Puppet Enterprise and Open Source Puppet

Security Compliance Enforcement uses Puppet policy-as-code (PaC) to enforce security configurations aligned to CIS Benchmarks and DISA STIGs, giving you a leg up on many compliance expectations and streamlining audit prep. In Puppet Enterprise, it is accessed through the included Security Compliance Management Console.

It can be applied to Puppet Enterprise or Open Source Puppet (see the compatibility list below).

Version information

  • 2.0.0 (latest)
released May 7th 2024
This version is compatible with:
  • Puppet Enterprise 2023.7.x, 2023.6.x, 2023.5.x, 2023.4.x, 2023.3.x, 2023.2.x, 2023.1.x, 2023.0.x, 2021.7.x, 2021.6.x, 2021.5.x, 2021.4.x, 2021.3.x, 2021.2.x, 2021.1.x, 2021.0.x, 2019.8.x
  • Puppet >= 6.23.0 < 9.0.0
  • , , , , ,
Tasks:
  • audit_duplicate_gid
  • audit_duplicate_group_names
  • audit_etc_shadow
  • audit_duplicate_uid
  • audit_duplicate_user_names
  • audit_boot
  • audit_check_ipv6
  • and 54 more. See all tasks

Documentation

puppetlabs/sce_linux — version 2.0.0 May 7th 2024

sce_linux

Product documentation is available on the Puppet Docs website.