Forge Home

codedeploy

Puppet module to manage the AWS CodeDeploy agent

82,779 downloads

79,790 latest version

4.3 quality score

We run a couple of automated
scans to help you access a
module's quality. Each module is
given a score based on how well
the author has formatted their
code and documentation and
modules are also checked for
malware using VirusTotal.

Please note, the information below
is for guidance only and neither of
these methods should be considered
an endorsement by Puppet.

Version information

  • 1.0.1 (latest)
  • 1.0.0 (deleted)
  • 0.1.2
  • 0.1.1
  • 0.1.0 (deleted)
released Feb 28th 2016
This version is compatible with:
  • Puppet Enterprise >= 3.2.0 < 2015.4.0
  • Puppet >= 3.4.0 < 5.0.0
  • , ,

Start using this module

  • r10k or Code Manager
  • Bolt
  • Manual installation
  • Direct download

Add this module to your Puppetfile:

mod 'walkamongus-codedeploy', '1.0.1'
Learn more about managing modules with a Puppetfile

Add this module to your Bolt project:

bolt module add walkamongus-codedeploy
Learn more about using this module with an existing project

Manually install this module globally with Puppet module tool:

puppet module install walkamongus-codedeploy --version 1.0.1

Direct download is not typically how you would use a Puppet module to manage your infrastructure, but you may want to download the module in order to inspect the code.

Download
Tags: aws, codedeploy

Documentation

walkamongus/codedeploy — version 1.0.1 Feb 28th 2016

AWS CodeDeploy Puppet Module

Build Status

Table of Contents

  1. Overview
  2. Module Description - What the module does and why it is useful
  3. Setup - The basics of getting started with codedeploy
  4. Usage - Configuration options and additional functionality
  5. Limitations - OS compatibility, etc.

Overview

This module installs and enables the AWS CodeDeploy agent.

Module Description

The AWS Codedeploy allows you to automatically deploy applications to AWS instances from S3 or GitHub. This module installs any required packages followed by the CodeDeploy agent. It then enables the codedeploy-agent service and ensures that it is running.

Setup

What codedeploy affects

  • Packages
    • codedeploy-agent
    • awscli (Debian)
  • Services
    • codedeploy-agent daemon

Usage

The codedeploy-agent package requires a version of Ruby > 2.0.x to be installed under /usr/bin/ruby. This dependency must be satisfied prior to installing the codedeploy-agent package. The recommended way of doing this is via the puppetlabs/ruby module.

Install the AWS CodeDeploy agent and ensure the agent is running

include '::ruby'
include '::codedeploy'