Forge Home

jpackage

A Puppet that ensures the jpackage repos are installed

12,085 downloads

9,427 latest version

3.0 quality score

We run a couple of automated
scans to help you access a
module's quality. Each module is
given a score based on how well
the author has formatted their
code and documentation and
modules are also checked for
malware using VirusTotal.

Please note, the information below
is for guidance only and neither of
these methods should be considered
an endorsement by Puppet.

Version information

  • 0.1.1 (latest)
  • 0.1.0
  • 0.0.1
released Aug 22nd 2014
This version is compatible with:
  • Puppet 3.x
  • , ,

Start using this module

  • r10k or Code Manager
  • Bolt
  • Manual installation
  • Direct download

Add this module to your Puppetfile:

mod 'yguenane-jpackage', '0.1.1'
Learn more about managing modules with a Puppetfile

Add this module to your Bolt project:

bolt module add yguenane-jpackage
Learn more about using this module with an existing project

Manually install this module globally with Puppet module tool:

puppet module install yguenane-jpackage --version 0.1.1

Direct download is not typically how you would use a Puppet module to manage your infrastructure, but you may want to download the module in order to inspect the code.

Download

Documentation

yguenane/jpackage — version 0.1.1 Aug 22nd 2014

puppet-jpackage

Build Status

Overview

A Puppet module that ensures the jpackage repositories are installed.

The JPackage Project has two primary goals:

  • To provide a coherent set of Java software packages for Linux, satisfying all quality requirements of other applications.
  • To establish an efficient and robust policy for Java software packaging and installation.

Usage

For the latest version :

include jpackage

For a specific version :

class {'jpackage':
  version => '5.0',
}

One can decide if repository should be enabled or not :

class {'jpackage':
  version       => '5.0',
  repo_enable   => true,
  update_enable => false,
}

Parameters

version

Version of jpackage that will be installed

repo_enable

Whether or not the main repository should be enabled

update_enable

Whether or not the update repository should be enabled

Limitations

This module works for :

  • EL 6
  • EL 5
  • Fedora 17