Forge Home

mofed

Mellanox OFED Puppet module

11,423 downloads

289 latest version

5.0 quality score

We run a couple of automated
scans to help you access a
module's quality. Each module is
given a score based on how well
the author has formatted their
code and documentation and
modules are also checked for
malware using VirusTotal.

Please note, the information below
is for guidance only and neither of
these methods should be considered
an endorsement by Puppet.

Version information

  • 3.1.0 (latest)
  • 3.0.0
  • 2.3.1
  • 2.3.0
  • 2.2.0
  • 2.1.0
  • 2.0.0
  • 1.5.0
  • 1.4.1
  • 1.4.0
  • 1.3.0
  • 1.2.0
released Apr 7th 2022
This version is compatible with:
  • Puppet Enterprise 2021.6.x, 2021.5.x, 2021.4.x, 2021.3.x, 2021.2.x, 2021.1.x, 2021.0.x, 2019.8.x, 2019.7.x, 2019.5.x, 2019.4.x, 2019.3.x, 2019.2.x, 2019.1.x
  • Puppet >= 6.1.0 < 8.0.0
  • , ,

Start using this module

  • r10k or Code Manager
  • Bolt
  • Manual installation
  • Direct download

Add this module to your Puppetfile:

mod 'treydock-mofed', '3.1.0'
Learn more about managing modules with a Puppetfile

Add this module to your Bolt project:

bolt module add treydock-mofed
Learn more about using this module with an existing project

Manually install this module globally with Puppet module tool:

puppet module install treydock-mofed --version 3.1.0

Direct download is not typically how you would use a Puppet module to manage your infrastructure, but you may want to download the module in order to inspect the code.

Download

Documentation

treydock/mofed — version 3.1.0 Apr 7th 2022

puppet-module-mofed

Puppet Forge CI Status

Table of Contents

  1. Overview
  2. Usage - Configuration options
  3. Reference - Parameter and detailed reference to all options
  4. Limitations - OS compatibility, etc.
  5. Development - Guide for contributing to the module
  6. TODO
  7. Additional Information

Overview

The MOFED Puppet module manages Mellanox OFED for Linux.

Usage

mofed

Install and configure MOFED from site specific yum repo server.

class { 'mofed':
  repo_baseurl => 'http://example.com/mlnx/$releasever/3.4-2.0.0.0-rhel7.3/'
  repo_gpgkey  => 'http://example.com/mlnx/$releasever/3.4-2.0.0.0-rhel7.3/RPM-GPG-KEY-Mellanox',
}

mofed::interface

Add IPoIB interface

mofed::interface { 'ib0':
  ensure         => 'present',
  ipaddr         => '10.0.0.1',
  netmask        => '255.255.0.0',
  connected_mode => 'no',
}

The same interface can be defined in Hiera if the mofed class is included

mofed::interfaces:
  ib0:
    ensure: 'present'
    ipaddr: '10.0.0.1'
    netmask: '255.255.0.0'
    connected_mode: 'no'    

mofed::opensm

Add opensm that is set for 2 ports.

class { 'mofed::opensm':
  ports => ['mlx4_1 1', 'mlx4_1 2'],
}

mofed::srp

Add srp for 2 ports.

class { 'mofed::srp':
  ports => ['mlx4_1 1', 'mlx4_1 2'],
}

Reference

http://treydock.github.io/puppet-module-mofed/

Facts

has_mellanox_infiniband

This boolean fact will return true if the system has a Mellanox Infiniband card.

mellanox_ofed_version

Returns the Mellanox OFED version that is installed

infiniband_hcas

Moved to treydock/infiniband module

infiniband_hca_port_guids

Moved to treydock/infiniband module

Limitations

This module has been tested on:

  • RedHat 7 x86_64

Development

Testing

Testing requires the following dependencies:

  • rake
  • bundler

Install gem dependencies

bundle install

Run unit tests

bundle exec rake test

If you have Vagrant >= 1.2.0 installed you can run system tests

bundle exec rake beaker

TODO

Further Information