Forge Home

globus

Globus Online module

18,289 downloads

123 latest version

4.7 quality score

We run a couple of automated
scans to help you access a
module's quality. Each module is
given a score based on how well
the author has formatted their
code and documentation and
modules are also checked for
malware using VirusTotal.

Please note, the information below
is for guidance only and neither of
these methods should be considered
an endorsement by Puppet.

Version information

  • 10.0.0 (latest)
  • 9.0.0
  • 8.0.0
  • 7.0.0
  • 6.0.1
  • 6.0.0
  • 5.2.0
  • 5.1.0
  • 5.0.0
  • 4.2.0
  • 4.1.0
  • 4.0.0
  • 3.0.1
  • 3.0.0
  • 2.1.0
  • 2.0.1
released Nov 29th 2023
This version is compatible with:
  • Puppet Enterprise 2023.5.x, 2023.4.x, 2023.3.x, 2023.2.x, 2023.1.x, 2023.0.x, 2021.7.x, 2021.6.x, 2021.5.x, 2021.4.x, 2021.3.x, 2021.2.x, 2021.1.x, 2021.0.x
  • Puppet >= 7.0.0 < 9.0.0
  • , , , ,

Start using this module

  • r10k or Code Manager
  • Bolt
  • Manual installation
  • Direct download

Add this module to your Puppetfile:

mod 'treydock-globus', '10.0.0'
Learn more about managing modules with a Puppetfile

Add this module to your Bolt project:

bolt module add treydock-globus
Learn more about using this module with an existing project

Manually install this module globally with Puppet module tool:

puppet module install treydock-globus --version 10.0.0

Direct download is not typically how you would use a Puppet module to manage your infrastructure, but you may want to download the module in order to inspect the code.

Download
Tags: hpc, globus, gridftp

Documentation

treydock/globus — version 10.0.0 Nov 29th 2023

puppet-globus

Puppet Forge CI Status

Overview

This module manages Globus Connect Server.

Supported Versions of Globus

Currently this module supports Globus 5.4, at least 5.4.61

Globus Version Globus Puppet module versions
4.x 3.x
4.x & 5.3 4.x
4.x & 5.4 5.x-9.x
5.4 10.x

Usage

Globus v5.4

The steps performed by this module are to install Globus and run the globus endpoint setup and globus node setup commands.

The following is the minimum parameters that must be passed to setup Globus v5.4.

class { 'globus':
  display_name  => 'REPLACE My Site Globus',
  owner         => 'REPLACE-user@example.com',
  organization  => 'REPLACE-My Site',
}

Globus CLI

To install the Globus CLI to /opt/globus-cli and create symlink for executable at /usr/bin/globus:

include globus::cli

Globus Timer

To install the Globus Timer CLI to /opt/globus-timer and create symlink for executable at /usr/bin/globus-timer:

include globus::timer

Globus SDK

To install the Globus SDK to /opt/globus-sdk:

include globus::sdk

Facts

The globus_info fact exposes the information stored in /var/lib/globus-connect-server/info.json. Example:

# facter -p globus_info
{
  endpoint_id => "1c6b6e6a-3791-4213-b3e6-00000001",
  domain_name => "00000001.8443.data.globus.org",
  manager_version => "5.4.11",
  DATA_TYPE => "info#1.0.0",
  client_id => "1c6b6e6a-3791-4213-b3e6-00000001",
  api_version => "1.3.0"
}

Reference

http://treydock.github.io/puppet-module-globus/

Compatibility

Tested using

  • RedHat/CentOS 7
  • RedHat/Rocky 8 & 9
  • Debian 11
  • Ubuntu 20.04 & 22.04