Forge Home

postfix

Manages the Postfix mail server

12,615 downloads

124 latest version

5.0 quality score

Version information

  • 5.7.0 (latest)
  • 5.6.0
  • 5.5.1
  • 5.5.0
  • 5.4.0
  • 5.3.0
  • 5.2.1
  • 5.2.0
  • 5.1.0
  • 5.0.3
  • 5.0.2
  • 5.0.1
  • 4.1.5
  • 4.1.4
released Aug 5th 2022
This version is compatible with:
  • Puppet Enterprise 2021.6.x, 2021.5.x, 2021.4.x, 2021.3.x, 2021.2.x, 2021.1.x, 2021.0.x, 2019.8.x
  • Puppet >= 6.22.1 < 8.0.0
  • , ,

Start using this module

  • r10k or Code Manager
  • Bolt
  • Manual installation
  • Direct download

Add this module to your Puppetfile:

mod 'simp-postfix', '5.7.0'
Learn more about managing modules with a Puppetfile

Add this module to your Bolt project:

bolt module add simp-postfix
Learn more about using this module with an existing project

Manually install this module globally with Puppet module tool:

puppet module install simp-postfix --version 5.7.0

Direct download is not typically how you would use a Puppet module to manage your infrastructure, but you may want to download the module in order to inspect the code.

Download
Tags: postfix, mail, mta, smtp, simp

Documentation

simp/postfix — version 5.7.0 Aug 5th 2022

License CII Best Practices Puppet Forge Puppet Forge Downloads Build Status

This is a SIMP module

This module is a component of the System Integrity Management Platform, a compliance-management framework built on Puppet.

If you find any issues, they can be submitted to our JIRA.

Please read our Contribution Guide.

Module Description

This module provides for the configuration of the postfix mail server.

Reference

Plesae see REFERENCE.md for a full reference.

Development

Please read our Contribution Guide.

Visit the project homepage and look at our issues on JIRA.