Forge Home

logrotate

configure SIMP logrotate

15,151 downloads

1,112 latest version

3.1 quality score

Version information

  • 6.6.0 (latest)
  • 6.5.1
  • 6.5.0
  • 6.4.0
  • 6.3.1
  • 6.3.0
  • 6.2.0
  • 6.1.2
  • 6.1.1
  • 6.1.0
  • 6.0.0
  • 4.1.1
  • 4.1.0
released Jul 7th 2021
This version is compatible with:
  • Puppet Enterprise 2021.6.x, 2021.5.x, 2021.4.x, 2021.3.x, 2021.2.x, 2021.1.x, 2021.0.x, 2019.8.x
  • Puppet >= 6.22.1 < 8.0.0
  • , ,

Start using this module

  • r10k or Code Manager
  • Bolt
  • Manual installation
  • Direct download

Add this module to your Puppetfile:

mod 'simp-logrotate', '6.6.0'
Learn more about managing modules with a Puppetfile

Add this module to your Bolt project:

bolt module add simp-logrotate
Learn more about using this module with an existing project

Manually install this module globally with Puppet module tool:

puppet module install simp-logrotate --version 6.6.0

Direct download is not typically how you would use a Puppet module to manage your infrastructure, but you may want to download the module in order to inspect the code.

Download
Tags: logrotate, simp

Documentation

simp/logrotate — version 6.6.0 Jul 7th 2021

License CII Best Practices Puppet Forge Puppet Forge Downloads Build Status

pupmod-simp-logrotate

Table of Contents

  1. Description
  2. Setup - The basics of getting started with logrotate
  3. Usage - Configuration options and additional functionality
  4. Reference
  5. Limitations - OS compatibility, etc.
  6. Development - Guide for contributing to the module

Description

Configure LogRotate global options.

Use logrotate::rule for specific configuration options.

Setup

What logrotate affects

Manages the following:

  • logrotate package
  • /etc/logrotate.conf file
  • /etc/logrotate.simp.d directory and its contents

Setup Requirements

This module requires the following:

Usage

class { 'logrotate': }

Reference

See REFERENCE.md.

Limitations

SIMP Puppet modules are generally intended for use on Red Hat Enterprise Linux and compatible distributions, such as CentOS. Please see the metadata.json file for the most up-to-date list of supported operating systems, Puppet versions, and module dependencies.

Development

Please read our Contribution Guide.

If you find any issues, they can be submitted to our JIRA.