Forge Home

mount_providers

Provides the mounttab and mountpoint resource types.

621,226 downloads

50,193 latest version

5.0 quality score

We run a couple of automated
scans to help you access a
module's quality. Each module is
given a score based on how well
the author has formatted their
code and documentation and
modules are also checked for
malware using VirusTotal.

Please note, the information below
is for guidance only and neither of
these methods should be considered
an endorsement by Puppet.

Version information

  • 2.0.1 (latest)
  • 2.0.0
  • 1.0.0
  • 0.0.3
  • 0.0.2
  • 0.0.1
released Mar 27th 2019
This version is compatible with:
  • Puppet Enterprise 2019.8.x, 2019.7.x, 2019.5.x, 2019.4.x, 2019.3.x, 2019.2.x, 2019.1.x, 2019.0.x, 2018.1.x, 2017.3.x
  • Puppet >= 5.0.0 < 7.0.0
  • , , , , , , ,

Start using this module

  • r10k or Code Manager
  • Bolt
  • Manual installation
  • Direct download

Add this module to your Puppetfile:

mod 'puppetlabs-mount_providers', '2.0.1'
Learn more about managing modules with a Puppetfile

Add this module to your Bolt project:

bolt module add puppetlabs-mount_providers
Learn more about using this module with an existing project

Manually install this module globally with Puppet module tool:

puppet module install puppetlabs-mount_providers --version 2.0.1

Direct download is not typically how you would use a Puppet module to manage your infrastructure, but you may want to download the module in order to inspect the code.

Download

Documentation

puppetlabs/mount_providers — version 2.0.1 Mar 27th 2019

Mount Providers

This module is designed to provide additional functionality and support the native mount type inside of Puppet. The module provides two additional resource types not provided by Puppet core:

  • mountpoint
  • mounttab

Please see the output of puppet describe mountpoint and puppet describe mounttab for more information about the types and providers supplied by this module.

Installation

This module is installable from the Puppet Forge using the puppet module command.

$ puppet module install puppetlabs-mount_providers

Source

Known Issues

This module will cause puppet describe to throw an error on Puppet versions between 2.6.8 and 2.6.14. The error is:

root@ubuntu-10:/etc/puppetlabs/puppet/modules# puppet describe mounttab
Could not run: Could not autoload /etc/puppetlabs/puppet/modules/puppetlabs-mount-providers/lib/puppet/type/mountpoint.rb:undefined method 'downcase' for nil:NilClass

Puppet has been patched to fix this bug. Please see Issue 13070 for details about when this fix has been released.