Forge Home

oraclejava

Install Oracle Java jdk6, 7, 8 or 9 via source, rpm or http proxy

27,129 downloads

22,686 latest version

4.6 quality score

We run a couple of automated
scans to help you access a
module's quality. Each module is
given a score based on how well
the author has formatted their
code and documentation and
modules are also checked for
malware using VirusTotal.

Please note, the information below
is for guidance only and neither of
these methods should be considered
an endorsement by Puppet.

Version information

  • 0.0.8 (latest)
  • 0.0.7
  • 0.0.6
  • 0.0.5
  • 0.0.4
  • 0.0.3
  • 0.0.2
  • 0.0.1
released Jan 22nd 2016
This version is compatible with:
  • , , ,

Start using this module

  • r10k or Code Manager
  • Bolt
  • Manual installation
  • Direct download

Add this module to your Puppetfile:

mod 'neillturner-oraclejava', '0.0.8'
Learn more about managing modules with a Puppetfile

Add this module to your Bolt project:

bolt module add neillturner-oraclejava
Learn more about using this module with an existing project

Manually install this module globally with Puppet module tool:

puppet module install neillturner-oraclejava --version 0.0.8

Direct download is not typically how you would use a Puppet module to manage your infrastructure, but you may want to download the module in order to inspect the code.

Download
Tags: java, oracle

Documentation

neillturner/oraclejava — version 0.0.8 Jan 22nd 2016

oraclejava

Puppet module to install Oracle JDK 9, 8, 7 or 6 by downloaded from the java oracle website.

NOTE: JRE not yet supported. Install relies on wget being installed

Minimal Usage

Install Java JDK7u79:

  class { 'oraclejava' : }

Install Java JDK7u79 via rpm:

  class { 'oraclejava::jdk7_rpm' : }

Install Java JDK8u71:

  class { 'oraclejava::jdk8' : }

Install Java JDK8u71 via rpm:

  class { 'oraclejava::jdk8_rpm' : }

Install Java JDK9b102:

  class { 'oraclejava::jdk9' : }

Complex Usage

Install Java JDK9b72

  class { 'oraclejava::jdk9' :
    java           => 'jdk-8b72',
    java_loc        => '/usr/java',
    java_dir        => 'jdk1.9.0_b72',
    download_url    => 'http://www.java.net/download/jdk9/archive/b72/binaries/jdk-9-ea-bin-b72-linux-x64-08_jul_2015.tar.gz'
  }

Install Java JDK8u11

  class { 'oraclejava::jdk8' :
    java           => 'jdk-8u11',
    java_loc        => '/usr/java',
    java_dir        => 'jdk1.8.0_11',
    download_url    => 'http://download.oracle.com/otn-pub/java/jdk/8u11-b01/jdk-8u11-linux-x64.tar.gz'
  }

Install Java JDK8u11 via rpm

  class { 'oraclejava::jdk8_rpm' :
    java_loc        => '/usr/java',
    java_dir        => 'jdk1.8.0_11',
    rpm_name        => 'jdk-8u11-linux-x64.rpm',
    download_url    => 'http://download.oracle.com/otn-pub/java/jdk/8u11-b01/jdk-8u11-linux-x64.rpm'
  }

Install Java JDK7u67 via rpm and an http proxy 10.99.99.99

 class { 'oraclejava::jdk7_rpm':
   java_loc        => '/usr/java',
   java_dir        => 'jdk1.7.0_67',
   rpm_name        => 'jdk-7u67-linux-x64.rpm',
   download_url    => 'https://edelivery.oracle.com/otn-pub/java/jdk/7u67-b01/jdk-7u67-linux-x64.rpm',
   wget_opts       => "-e use_proxy=yes -e http_proxy=10.99.99.99:3128  -e https_proxy=10.99.99.99:3128",
   require         => Class['epel']
 }

To determine the values for latest release of Java versions:

https://jdk9.java.net/download/

http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html

http://www.oracle.com/technetwork/java/javase/downloads/jdk7-downloads-1880260.html

To determine the values for older releases of Java versions:

http://www.oracle.com/technetwork/java/javase/downloads/java-archive-javase8-2177648.html

http://www.oracle.com/technetwork/java/javase/downloads/java-archive-downloads-javase7-521261.html

http://www.oracle.com/technetwork/java/javasebusiness/downloads/java-archive-downloads-javase6-419409.html