Forge Home

beansbooks

Installs and configures System76's Beansbooks

7,684 downloads

7,585 latest version

5.0 quality score

We run a couple of automated
scans to help you access a
module's quality. Each module is
given a score based on how well
the author has formatted their
code and documentation and
modules are also checked for
malware using VirusTotal.

Please note, the information below
is for guidance only and neither of
these methods should be considered
an endorsement by Puppet.

Version information

  • 0.1.2 (latest)
  • 0.1.1
released Apr 24th 2016
This version is compatible with:

Start using this module

  • r10k or Code Manager
  • Bolt
  • Manual installation
  • Direct download

Add this module to your Puppetfile:

mod 'monkygames-beansbooks', '0.1.2'
Learn more about managing modules with a Puppetfile

Add this module to your Bolt project:

bolt module add monkygames-beansbooks
Learn more about using this module with an existing project

Manually install this module globally with Puppet module tool:

puppet module install monkygames-beansbooks --version 0.1.2

Direct download is not typically how you would use a Puppet module to manage your infrastructure, but you may want to download the module in order to inspect the code.

Download

Documentation

monkygames/beansbooks — version 0.1.2 Apr 24th 2016

beansbooks

Puppet Forge

Overview

Installs and configures System 76's Beansbooks cloud accounting platform.

Module Description

Installs and configures apache & postgresql from the puppetforge. Downloads the source for System76's Beansbooks (php) and sets up web site.

Usage

The most basic usage is the following:

class {'beansbooks':
  sha_hash             => 'hash',
  sha_salt             => 'salt',
  cookie_salt          => 'cookie_salt',
  key                  => 'key',
  admin_user_full_name => 'admin',
  admin_user_email     => 'admin@admin.com',
  admin_user_pass      => 'admin',
}

###Class: beansbooks

The main class for deploying beansbooks. This is the only necessary class to declare.

Required Parameters

sha_hash

A strong key defined here: beansbooks/application/classes/beans/example.config.php

sha_salt

A strong key defined here: beansbooks/application/classes/beans/example.config.php

cookie_salt

A strong key defined here: beansbooks/application/classes/beans/example.config.php

key

A strong key defined here: beansbooks/application/classes/beans/example.config.php

admin_user_full_name

The full name of the admin or owner of the site.

admin_user_email

The admin's email address.

admin_user_pass

The password of the admin user (to login to the web site.

Optional Parameters

servername

The FQDN or hostname of the server.
Default: 'localhost'

db_host

The name or ip of the host for the database.
Default: 'localhost'

db_user

The database user name for accessing beansbooks data.
Default: 'beans'

db_pass

The password for accessing the database.
Default: 'beans'

db_name

The name of the database to store the beansbooks data.
Default: 'beansdb'

db_root_pass

The password for the root database user.
Default 'beans'

version

The beansbooks release version (label on github).
Default: 'v1.5.2'

timezone

A string that represents the php timezone.
Valid values: http://php.net/manual/en/timezones.php Default: 'GMT'

ssl_cert

The path to the ssl certificate file to be set in the vhost.
Default: '/etc/ssl/certs/ssl-cert-snakeoil.pem'

ssl_key

The path to the key to the certificate file to be set in the vhost.
Default: '/etc/ssl/private/ssl-cert-snakeoil.key'

ssl_chain

The path to the ssl chain file (rootca) in the vhost.
Default: undef

Testing

This module has been tested on the following beansbooks versions:

  • v1.5.1
  • v1.5.2

Vagrant Environment

This module uses vagrant and puppet for testing. The vagrant directory contains the testing configuration.

Setup

Install the following programs:

  • virtualbox
  • vagrant
  • puppet

To run a test, do the following:

  • cd to the vagrant directory
  • run the run.bash script
  • use a browser to login to the site at 192.168.33.12

Limitations

Only works with debian based OS's.

Development

The module is open source and available on bitbucket. Please fork!