Forge Home

katello

Handles deploying and managing a Katello + Foreman server

40,645 downloads

137 latest version

5.0 quality score

Version information

  • 22.0.0 (latest)
  • 21.6.0
  • 21.5.0
  • 21.4.0
  • 21.3.0
  • 21.2.0
  • 21.1.0
  • 21.0.0
  • 20.0.0
  • 19.0.0
  • 18.0.0
  • 17.0.0
  • 16.1.0
  • 16.0.0
  • 15.0.0
  • 14.1.0
  • 14.0.0
  • 13.0.0
  • 12.0.0
  • 11.0.0
  • 10.1.1
  • 10.1.0
  • 10.0.0
  • 9.0.2
  • 9.0.1
  • 9.0.0
  • 8.2.3
  • 8.2.2
  • 8.2.1
  • 8.2.0
  • 8.1.0
  • 8.0.1
  • 8.0.0
  • 7.2.0
  • 7.1.0
  • 7.0.1
  • 7.0.0
  • 6.1.1
  • 6.1.0
  • 6.0.3
  • 6.0.2
  • 6.0.1
  • 6.0.0
  • 5.1.1
  • 5.1.0
  • 5.0.1
  • 5.0.0
  • 4.0.0
  • 3.1.0
  • 3.0.0
  • 2.0.2
  • 2.0.1
  • 2.0.0
  • 1.0.2
  • 1.0.0
released Aug 4th 2022
This version is compatible with:
  • Puppet Enterprise 2021.6.x, 2021.5.x, 2021.4.x, 2021.3.x, 2021.2.x, 2021.1.x, 2021.0.x, 2019.8.x, 2019.7.x
  • Puppet >= 6.15.0 < 8.0.0
  • ,

Start using this module

  • r10k or Code Manager
  • Bolt
  • Manual installation
  • Direct download

Add this module to your Puppetfile:

mod 'katello-katello', '22.0.0'
Learn more about managing modules with a Puppetfile

Add this module to your Bolt project:

bolt module add katello-katello
Learn more about using this module with an existing project

Manually install this module globally with Puppet module tool:

puppet module install katello-katello --version 22.0.0

Direct download is not typically how you would use a Puppet module to manage your infrastructure, but you may want to download the module in order to inspect the code.

Download

Documentation

katello/katello — version 22.0.0 Aug 4th 2022

Puppet Forge Build Status

Table of Contents

  1. Overview
  2. What katello affects
  3. Limitations - OS compatibility, etc.
  4. Development - Guide for contributing to the module

Overview

This module is designed to setup a full katello server, including candlepin, pulp and qpid.

What katello affects

  • Installs and configures Katello
  • Installs additional required services

Limitations

  • OS Support and other requirements should be checked in the metadata.json

Development

See the CONTRIBUTING guide for steps on how to make a change and get it accepted upstream.